[scodoc-devel] Migration de Debian 7 vers Debian 8

Jerome BONGAIN jerome.bongain at univ-fcomte.fr
Mar 30 Mai 08:14:35 CEST 2017


Bonjour,

Merci pour vos réponses, je pars sur une nouvelle installation.

Bien cordialement

index
/        Jérôme BONGAIN /
IUT Besançon - Vesoul <http://iut-bv.univ-fcomte.fr/>
	PIAM - Pôle Informatique, Audiovisuel & Multimédia
IUT Besançon - Vesoul / Site de Besançon
*30, avenue de l'observatoire
BP 1559
25009* Besançon cedex
*Tél :* (+33) (0)3 81 66 *60 95
**Mail : jerome.bongain at univ-fcomte.fr*

Le 29/05/2017 à 22:24, Emmanuel Viennet a écrit :
> Bonjour
>
> la seule méthode supportée est celle décrite dans la doc.
> https://trac.lipn.univ-paris13.fr/projects/scodoc/wiki/MigrationDonneesScoDoc
>
> On y lit "Au lieu de mettre à jour le système Debian, il est
> préférable de réinstaller complètement un nouveau serveur."
>
> Cordialement,
> Emmanuel, en mode RTFM
>
> Le 29 mai 2017 à 14:27, Jerome BONGAIN <jerome.bongain at univ-fcomte.fr> a écrit :
>> Bonjour,
>>
>> J'ai des difficultés à migrer mon serveur qui héberge Scodoc vers Debian 8
>> (jessie). Tout fonctionne parfaitement actuellement en version 7.7
>> (subversion 1642M) sous Debian 7.
>>
>> Pour migrer, j'ai testé deux méthodes :
>>
>> - La première, exclusivement en lançant le script fourni ./upgrade.sh, après
>> avoir modifié le fichier sources.list pour pointer sur "Jessie"
>> J'ai une erreur :
>> svn: E155019: Can't upgrade '/opt/scodoc/Products/ScoDoc/misc' as it is not
>> a working copy root, the root is '/opt/scodoc/Products/ScoDoc'
>> Stopping ScoDoc...
>>
>> Donc, sur les conseils de M. Viennet, j'ai renommé le répertoire misc en
>> misc.bak, puis j'ai lancé la commande svn up
>> J'ai toujours des erreurs et l'application ne repart pas.
>>
>> - Deuxième méthode qui ne change rien au problème :
>>
>> Je mets d'abord à jour le Système, puis Scodoc :
>> apt-get update && apt-get upgrade && apt-get dist-upgrade -y
>> apt-get autoremove
>>
>> cd /opt/scodoc/Products/ScoDoc/config
>> ./upgrade.sh
>>
>> J'ai toujours des erreurs de dépendance, comme si le script ./upgrate.sh
>> pointait toujours sur l'ancienne version de Debian.
>>
>> Merci pour votre aide, début d'explication ou retour d'expérience.
>> PS : S'il existe une doc de migration, je suis preneur.
>>
>> Cordialement
>> --
>>          Jérôme BONGAIN
>>
>> PIAM - Pôle Informatique, Audiovisuel & Multimédia
>> IUT Besançon - Vesoul / Site de Besançon
>> 30, avenue de l'observatoire
>> BP 1559
>> 25009 Besançon cedex
>> Tél : (+33) (0)3 81 66 60 95
>> Mail : jerome.bongain at univ-fcomte.fr
>>
>> _______________________________________________
>> scodoc-devel mailing list
>> scodoc-devel at listes.univ-paris13.fr
>> https://listes.univ-paris13.fr/mailman/listinfo/scodoc-devel

-------------- section suivante --------------
Une pièce jointe HTML a été nettoyée...
URL: https://listes.univ-paris13.fr/pipermail/scodoc-devel/attachments/20170530/3fc9ef3b/attachment-0001.htm 
-------------- section suivante --------------
Une pièce jointe non texte a été nettoyée...
Nom: logo.jpg
Type: image/jpeg
Taille: 24194 octets
Desc: non disponible
Url: https://listes.univ-paris13.fr/pipermail/scodoc-devel/attachments/20170530/3fc9ef3b/attachment-0001.jpg 


Plus d'informations sur la liste de diffusion scodoc-devel