[scodoc-devel] Fwd: [Notes IUT] Mise en place Scodoc

Emmanuel Viennet emmanuel.viennet at iutv.univ-paris13.fr
Sam 9 Déc 09:05:55 CET 2017


---------- Message transféré ----------
De : Patrick Aymar <patrick.aymar at univ-tours.fr>
Date : 8 décembre 2017 à 17:40
Objet : Re: [Notes IUT] Mise en place Scodoc
À : Emmanuel Viennet <emmanuel.viennet at iutv.univ-paris13.fr>


Bonsoir,

J’ai trouvé mon erreur, c’était sur mon serveur web, le prog php
générait un warning de timezone au lieu du XML.

merci pour ta réactivité.

Patrick Aymar


> Le 8 déc. 2017 à 12:35, Emmanuel Viennet <emmanuel.viennet at iutv.univ-paris13.fr> a écrit :
>
> Bonjour
>
> je ne réponds pas sur la liste "notes" car c'est très technique.
>
> Le XML renvoyé semble incorrect...
>
> Pour débugguer
> tu peux ajouter un log dans
> sco_utils.py
> ligne 691
>
> ajouter:
>
> log(data)
>
>
> et ensuite (après redémarrage de ScoDoc), regarder /opt/scodoc/log/notes.log
> (par exemple tail -f /opt/scodoc/log/notes.log dans un terminal
> pendant que vous testez)
>
> Emmanuel
>
>
>
> Le 8 décembre 2017 à 12:22, Patrick Aymar
> <patrick.aymar at univ-tours.fr> a écrit :
>> Bonjour,
>>
>> Je suis en train de mettre en place Scodoc pour le département GEA de l’IUT
>> de Tours.
>> Nous avons une installation de Scodoc qui est utilisée par d’autres
>> départements.
>> Pour GEA j’ai récupéré un ppn et j’ai créé un semestre.
>> J’essaye maintenant d’importer les étudiants de première année depuis un
>> export Apogée et un getEtud.php, il n’y à pas d’étudiant dans ma base pour
>> le moment.
>> Le getEtapes.php m’a permis de paramétrer l’étape dans le paramétrage du
>> semestre avec la VDI à 2, par contre je n’ai pas mis d’éléments.
>> Par contre,un indice peut-être, le paramétrage de l’URL du portail ne
>> fonctionne pas (time out) pour mon département (c’est l’URL d’un serveur sur
>> Internet), j’ai donc mis les urls des programmes php getEtud.php et
>> getEtapes.php.
>> Le code php fonctionne pour un autre département. Pour GEA j’ai indiqué
>> l’URL dans URL listant les étudiants Apogée du paramétrage.
>> J’ai débugé le code php et il est bien exécuté et lit bien mon csv lorsque
>> j’exécute « Synchroniser avec Etapes Apogée » ou lorsque je lance
>> re-interroger Apogée à la création manuelle d’un étudiant.
>> Par contre j’ai l’erreur suivante (cf pj), quelques soit les echo de XML
>> exécutés par le PHP et cela quelques soit le paramétrage de l’étape dans le
>> semestre.
>> Avant d’essayer de débuger le sco_portal_apogee.py je me permets de poster
>> ici pour savoir si ce problème vous évoque quelque chose.
>>
>> Bien cordialement
>>
>> Patrick Aymar
>>
>> Chef de département GEA
>> IUT de Tours
>>
>> _______________________________________________
>> notes mailing list
>> notes at listes.univ-paris13.fr
>> https://listes.univ-paris13.fr/mailman/listinfo/notes
>
>
>
> --
>
> Emmanuel Viennet
>
> Département Réseaux & Télécommunications
> IUT de Villetaneuse
> http://www.iutv.univ-paris13.fr/



-- 

Emmanuel Viennet

Département Réseaux & Télécommunications
IUT de Villetaneuse
http://www.iutv.univ-paris13.fr/


Plus d'informations sur la liste de diffusion scodoc-devel