[Scodoc-devel] Fwd: Re: installation scodoc 7 - erreur dans la doc

Emmanuel Viennet emmanuel.viennet at univ-paris13.fr
Ven 4 Oct 18:07:08 CEST 2013


Bonsoir,

le script de mise à jour (update.sh) était effectivement incorrect
(j'avais oublié de l'intégrer dans le svn !).

En revanche, je ne sais pas pourquoi le service ScoDoc n'a pas démarré chez toi.

Pour essayer de rattraper le coup:

cd /opt/scodoc/Products/ScoDoc
svn update
cd config
./upgrade.sh


Emmanuel





On Fri, Oct 4, 2013 at 12:06 PM, Jean-Michel DECROIX
<jean-michel.decroix at iscid-co.fr> wrote:
>
>
> Bonjour
>
> pas d'erreur à l'install (revision 1268 - que je viens juste d'effectuer)
>
> mais juste un
>
> Service Temporarily Unavailable
>
> The server is temporarily unable to service your
> request due to maintenance downtime or capacity
> problems. Please try again later.
>
> lors de ma premiere connection.
>
> zope ne se lance pas ?
> pas eu le temps d'explorer le probleme
>
> j'ai une erreur au lancement de ./upgrade.sh
>
>>>>
>
> root at scodoc:/opt/scodoc/Products/ScoDoc/config# ./upgrade
>
> -bash: ./upgrade: No such file or directory
>
> root at scodoc:/opt/scodoc/Products/ScoDoc/config# ./upgrade.sh
>
> Stopping ScoDoc...
>
> Stopping zope daemon: daemon manager not running
>
> Using SVN to update /opt/scodoc/Products/ScoDoc...
>
> At revision 1269.
>
> Stopping ScoDoc...
>
> Stopping zope daemon: daemon manager not running
>
> Using SVN to update /opt/scodoc/Products/ScoDoc...
>
> At revision 1269.
>
> ./install_reportlab23.sh: line 13: python2.4: command not found
>
> Trying to install reportlab version 2.3
>
> Reading package lists... Done
>
> Building dependency tree
>
> Reading state information... Done
>
> wget is already the newest version.
>
> The following packages were automatically installed and are no longer
> required:
>
>   libart-2.0-2 python-renderpm
>
> Use 'apt-get autoremove' to remove them.
>
> 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
>
> /tmp /opt/scodoc/Products/ScoDoc/config
>
> --2013-10-04 13:51:23--  http://www.reportlab.com/ftp/reportlab-2.3.tar.gz
>
> Resolving www.reportlab.com (www.reportlab.com)... 217.147.86.65
>
> Connecting to www.reportlab.com (www.reportlab.com)|217.147.86.65|:80...
> connected.
>
> HTTP request sent, awaiting response... 200 OK
>
> Length: 1857239 (1.8M) [application/x-gzip]
>
> Saving to: `reportlab-2.3.tar.gz.3'
>
> 100%[======================================>] 1,857,239   1.88M/s   in 0.9s
>
> 2013-10-04 13:51:24 (1.88 MB/s) - `reportlab-2.3.tar.gz.3' saved
> [1857239/1857239]
>
> Reading package lists... Done
>
> Building dependency tree
>
> Reading state information... Done
>
> E: Unable to locate package python2.4-dev
>
> E: Couldn't find any package by regex 'python2.4-dev'
>
> Reading package lists... Done
>
> Building dependency tree
>
> Reading state information... Done
>
> Package 'python-reportlab' is not installed, so not removed
>
> The following packages were automatically installed and are no longer
> required:
>
>   libart-2.0-2 python-renderpm
>
> Use 'apt-get autoremove' to remove them.
>
> 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
>
> ./install_reportlab23.sh: line 30: python2.4: command not found
>
> /opt/scodoc/Products/ScoDoc/config
>
> ./install_simplejson.sh: line 23: python2.4: command not found
>
> simplejson installed
>
> ./install_psycopg2.sh: line 19: python2.4: command not found
>
> Installing pyscopg2
>
> Reading package lists... Done
>
> Building dependency tree
>
> Reading state information... Done
>
> gcc is already the newest version.
>
> The following packages were automatically installed and are no longer
> required:
>
>   libart-2.0-2 python-renderpm
>
> Use 'apt-get autoremove' to remove them.
>
> 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
>
> ./install_psycopg2.sh: line 28: python2.4: command not found
>
> Executing post-upgrade script...
>
> Traceback (most recent call last):
>
>   File "/opt/scodoc/Products/ScoDoc/config/postupgrade.py", line 13, in
> <module>
>
>     from scodocutils import *
>
>   File "/opt/scodoc/Products/ScoDoc/config/scodocutils.py", line 4, in
> <module>
>
>     import sys, os, psycopg, glob, subprocess, traceback, time
>
> ImportError: No module named psycopg
>
> Executing post-upgrade database script...
>
> /usr/bin/env: python2.4: No such file or directory
>
> Starting ScoDoc...
>
> $Starting Zope: /opt/scodoc/instance/bin/zopectl start
>
> .
>
> daemon process started, pid=3745
>
>
>
>
>
>
> Le 04/10/2013 11:17, Emmanuel Viennet a écrit :
>>
>> 2013/10/4 Jean-Michel DECROIX<jean-michel.decroix at iscid-co.fr>:
>>>
>>> Bonjour
>>>
>>> dans le guide d'install debian 6
>>>
>>>      cd /opt/scodoc/instance/Products/ScoDoc/config
>>>      ./install_debian6.sh
>>>
>>>
>>> et dans le guide d'install debian 7
>>>
>>> cd /opt/scodoc/Products/ScoDoc/config ./install_debian7.sh
>>>
>>> y manque pas un "/instance" ?
>>
>> Non, c'est voulu et lié au changement de version de Zope.
>>
>> J'ai mis un lien symbolique "instance" pour que tous vos scripts
>> utilisant l'ancien chemin soient compatibles, et commencé à changer la
>> doc et les scripts scodoc.
>>
>> Sinon, l'installation a bien marché ?
>>
>> Merci
>> Emmanuel
>>
>>
>>
>>
>>
>>> --
>>> Jean-Michel DECROIX
>>> Technicien Informatique
>>> ISCID-CO Longuenesse
>>> 03.21.38.85.26
>>>
>>> _______________________________________________
>>> Scodoc-devel mailing list
>>> Scodoc-devel at rt.iutv.univ-paris13.fr
>>> https://www-rt.iutv.univ-paris13.fr/mailman/listinfo/scodoc-devel
>
>
>
> --
> Jean-Michel DECROIX
> Technicien Informatique
> ISCID-CO Longuenesse
> 03.21.38.85.26
>
>
>
> _______________________________________________
> Scodoc-devel mailing list
> Scodoc-devel at rt.iutv.univ-paris13.fr
> https://www-rt.iutv.univ-paris13.fr/mailman/listinfo/scodoc-devel


Plus d'informations sur la liste de diffusion Scodoc-devel